Wednesday, August 17, 2005


It's Alive!

Finally this thing is showing some real progress! :) In the last couple of days I've successfully fixed both the "Score Reels From Hell" problem and "The Outhole Problem". Yey!

First one was due to massive layers of dust and grease on the score reels. What I did was take everything apart, clean off dust and grease, sand the bakelite disk with the brass contacts, adjust the switches, clean the plastic score drum with Novus 2, and put it all together again after testing all the contacts with a multimeter. After cleaning 10 out of 20 of them the SRFH problem was gone. I will do the last 10 when I get the courage.

The outhole problem was easy, and merely a bad adjusted switch and the fact that I didn't trip the outhole switch manually in place of a ball.

With both these problems fixed the reset sequence completes and a new game is started! After some initial problems with playfield logic it turned out that a couple of the switches on the score motor was way off, and after ajusting them most of the game logic seems to work. There are still some problems in the top eject area and with the extra ball setting, but I think I know how to fix it.

Next up is to clean and ajust the rest of the stepper units so that multiplayer action will work. Then maybe soon I can start som real playtesting with an actuall ball? :)

Saturday, August 13, 2005


There's Meaning To The Madness

Today the manual and schematics finally arrived at my friends place in Boston, US. He will scan them and e-mail me the crucial parts so I have something to work with. First thing I got was the reset sequence which is:
  1. Credit unit reset coil is energized by switch on reset relay, thru score motor index cam switch A, credit button, zero switch on credit unit, and switch on game-over relay or coin unit last position break switch.

  2. End-of-stroke switch on credit unit reset coil will energize coin relay.

  3. Switches on coin relay will run score motor, trip game-over relay, and energize reset relay.

  4. Switches on reset relay will open circuits to playfield switches and outhole relay, run score motor, energize reset coils on coin unit-ball count unit-player unit and game-over relay, pulse no. 1, no. 2 and no. 3 reset relays, and reset left & right bonus units to zero.

  5. Switches on no. 1, no. 2 and no. 3 reset relays, will pulse the (20) scoring drum units until they reach zero.

  6. When reset delay drops out, outhole relay is energized thru zero switch on left bonus unit, switch on alternator relay, outhole switch, delay relay and index cam switch ‘C’

  7. Switches on outhole relay will run score motor, pulse both bonus unit S.U. Coils, and pulse ball release coil to propel ball toward plunger.
I got some inspiering answers to my previous post about the matter (thanks Norm, Billg and Grojohn), so today I went to work with new glow.

First, i unplugged everything from the main board (backbox, coin door, playfield, power-switch and chimes). Then powered up and manually tripped the Reset Relay. What happened was:
So far so good, this should indicate that the problem is not with the main board, right? It also fits with the reset sequence from the manual. I also tried tripping the coin relay, which is one step before the reset relay in the sequence, and same thing happenes.

Then I connected the playfield. Still everything fits with the sequence in the manual, bonus steppers are reset and the motor stops by itself, BUT, one thing that doesn' happen is the point where the reset relay de-energizes and the outhole relay is energized, causing a new ball to be pushed to the plunger (6) Tripping the outhole relay manually does exactly as the manual says (7), so somewhere between the reset relay de-energizing, and the outhole relay firering there is an error.

I will name this "The Outhole Problem" for now :) Maybe this happens because the backbox is not connected? I'm not to sure where the "switch on alternator relay" is. Is it on the Altenator Unit (main board), or on the Alternating Relay (playfield)? And the "outhole switch"? All I can see is an Outhole Relay. I guess the " index cam switch ‘C’." is on the score motor, but it's hard to tell where as I don't have the manual pages for that part yet.

Anyways, I momentarily gave up after checking the obvious stuff, and connect the backbox. Now I got the old problem with the reset relays firering in the backbox, causing all score wheels to 000000, but no motor stop. So, the old problem, "Score Reels From Hell", is probably in the back box? I try to force the reset relay to de-energize and that stops the motor, but also leaves a wheel coil in the back box energized.

I will try to clean every single one of those darn score wheels tomorrow and see if that makes any difference. But one thing puzzles me. One of the reset switches on each and every score wheel is always "connected", or, at least it beeps when I put my multimeter to it. This is the top switch in the picture below. Is this correct? This is also present on the Alternator Unit on the main board, which switches a switch on and of with every fire of the coil. Though the switch beeps in both positions. A short somewhere, or expected behavior?

Thanks to anyone who bothered to read this far! If you have any idea why all of this is happening, please let me know with a comment! :)

RGP post here

Friday, August 12, 2005


To Oil Or Not To Oil, That Is The Question

Okey, I've read the PinballHQ EM repair guide, and it's pretty strict on lubrication:
Electro-Mechanical machines, for the most part, do not require any lubrication. Most parts run "dry". Far more damage can be done to a machine by over-lubricating, than by under-lubricating. As a rule, if in doubt as to lubrication, don't do it! ... The only parts that will require any lubrication are metal-to-metal moving parts. There aren't very many in an EM game. So keep that lubrication in the tool box and away from the game.
So far I've stayed clear of any oil, but after going over some of the stepper units and drop targets in the machine I'm starting to wonder if maybe these classify as "metal-to-metal" moving parts. Small shafts that are supposed to move without any friction are very slugish and almost stuck, and I'm not sure how to fix this. They seem to have been oiled some time in the past, but that might have been a mistake? So, should I oil these parts, or should they be cleaned and sanded?

I'm spesifically talking about the drop target mechanical joints marked in the picture below:

And the shafts in the stepper units:

Oil, or no oil? And if no oil, what to clean it with to remove the old oil and how to make it's movement smooth and without friction? I guess that is the question.

RGP post here


Another One Bites The Dust

After som initial valve problems with the compressor I finally got the thing working yesterday. It was time to get rid of all the dust and soot on the main board and in the backbox. Here are some pictures from the session.

After removing the actual box from the backbox, leaving the reels and relays, I noticed that the paint on the backbox glass was very loose and would fall off in small pieces when looked at. I guess I have to fix it with some kind of spray, if that's possible. Will get back to that after the reset problem.

Thursday, August 11, 2005


Reset Sequence Not Completing

I've had some progress with the machine, but I'm still having a major problem with the reset sequence. For some reason it won't complete. Here is what happenes after I manually trigger the Coin Relay (which triggers the reset sequence):

  1. The score motor starts running (the blue box in the picture below)

  2. The "No. 2/3/? Reset" relays in the backbox fires in a pattern with the two leftmost (red in the picture below) firering at the same time, alternating with the rightmost (yellow). This resets all the score wheels to 0000000 where they stop.

  3. After a second or so, the Game Over Relay Latch is fired, and "Game Over" is no longer displayed in the back box. Instead the ball number and player up is lit. Player up is 1.

  4. The Target Relay (on the playfield, next to one of the bonus steppers) is fired and locks

  5. Both Bonus Steppers under the playfield locks the reset coil, and sporadically fire the step down coil (step to 0 because of the reset coil locked).

  6. The two kickers to the left and right of the playfield fire and kick

  7. The target relay is de-energized and the whole sequence from 4 is repeated.

I've opened and cleaned the two bonus steppers, and I'm fairly sure that the two player steppers (backbox and bottom cab) are zeroed. Same with ball count which displays 1. And all the score reels are zeroed. So it seems that everything is zeroed, but this is not passed on to the part supposed to stop all this noise :) Is this possible? Also, what has the Target Relay got to do with anything? Seems like it's firering in every little sequence I've tried.

If anyone has a clue why the machine is not reseting, please let me know in the comments! There is also a RGP post with the same topic here.

Monday, August 08, 2005


Score Reels From Hell

First problem: When the machine starts reseting the score reels it just continues to rotate the score motor forever. I understand from the guide at PinballHQ that this is due to the zero-reset switches not getting through to stop the score motor, but:

What is it that stops the score reels themselves at '0'? Cause if I put all score reels manually to 1, and then let the reset sequence start, they all count up to 6,7,8,9,and then 0, and stop there. So something is stopping them at 0, but the score motor keeps running, and the no 2/3 reset relays in the back cabinet keeps firering. Are there two separate mechanisms for stopping the actual reel at 0 and telling the motor it is at 0? Is that why there are two 0 reset switches?

Also, when i put the reels at 0, both of the 0 reset switches open, but one of them 'beeps' when i measure it with a MM. So basically it's closed all the time, even though it opens physically. Is this expected (has something to do with varying resistance?), or a short further down the line?

If anyone has any input on this, please use the comment field and let me know :)

See original RGP post here


First Few Steps

Hi and welcome to my blog/project page for the restoration of a 1976 Williams Grand Prix Pinball. I'll keep this site more or less up to date with my progress, and probably post a lot of questions too. Stay tuned!

This page is powered by Blogger. Isn't yours?